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In this guide, we refer to "Analytics Backup by QA" as "GABQ" for short.
“WP" is an abbreviation for “WordPress.”
Google Universal Analytics may be abbreviated as 'UA'.
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Before Setting Up “Analytics Backup by QA”　　　

Check✔️

I have thoroughly read and understood the Preparation Guide.

I have configured server and communication settings according to the

Preparation Guide.

I have prepared the WordPress environment following the Preparation

Guide.

I have downloaded the zip from the software download page.

▼Preparation Guide
https://ga-backup.com/wp-content/uploads/gabq-preparation-guide_EN.pdf

▼Software Download Page
https://ga-backup.com/en/gabqdownload/
The password for the page can be found in the email sent to you under the subject
"[Analytics Backup by QA] Your License and Download Information."

https://ga-backup.com/wp-content/uploads/gabq-preparation-guide_EN.pdf
https://ga-backup.com/en/gabqdownload/


Analytics Backup by QA Setup　　　　　　　　　

Make sure to read the Preparation Guide beforehand and configure your environment
before starting the backup process.

⁕ Have many licenses?
You need to set up Analytics Backup by QA in each WordPress.

1. Install Analytics Backup by QA to WP

1) Login to WordPress admin.
2) Go to "Plugins" > "Add New" > "Upload Plugin", then upload the zip file (gabq.zip).
3) Activate the plugin.

⁕ Have many licenses?
　　　Upload the zip file to each WordPress.

　

2. Register Email

Go to "License Activation" and register your email.

Notice email would be sent to you.
The WordPress administrator's address is initially entered, but you can change it to any
address you want. Enter the address you want to receive the notification email. (It does
not have to be the same as the email address for the license in Step 3-3 below.)

⁕ Have many licenses?
If you have more than one license, you can set up different email addresses for
each GABQ.



3. GABQ License Activation

Enter the "License Key" and “License ID (email address)" that we sent you and click
"Activate the license".

⁕ Have many licenses?
License keys that have been activated on another GABQ cannot be used.
Make sure you authorize the right license key for the license content you want
to use for that WP.



4. Google API Integration (Backup Settings ①)

　　GABQ needs to integrate with Google API to get (back up) your data from UA.
Client ID and client secret created at Google Cloud are required for linkage.

⁕ Have many licenses?
There is one WP = "one redirect URI" for one license. It is recommended to
create a project for each WP.
See also “Preparation Guide - Step 1. How many Google Cloud projects
should I create?”

　

(1) Create a project on Google Cloud.
　Enable "Google Analytics API" and "Google Analytics Reporting API" libraries.
　The redirect URI is shown on GABQ > Backup Settings.

▼How to:

① Use Chrome browser and sign in with your Google account

② Go to Google Cloud > Manage resources
https://console.cloud.google.com/cloud-resource-manager

③ Create a project

https://console.cloud.google.com/cloud-resource-manager


④ Select the project. Click [Navigation menu] > [API & Services] > [Library]

⑤ Enable "Google Analytics API" and "Google Analytics Reporting API" libraries.
　 Search by the words “google analytics” would help.

Select and enable the APIs. You may need to do it one by one. Make sure you
enable both of them.

Enabled “Google Analytics Reporting API”
Enabled “Google Analytics API”

⑥ Go to [API & Services] > [OAuth consent screen]

⑦ Choose “External” for User Type and click “CREATE”



⑧ Edit app registration.

　➊ OAuth consent screen

● App information
○ App name … Enter a name you want to.
○ User support email … Select your Google account

email address.
○ App logo … Ignore.

● App domain … Ignore.
● Developer contact information … Enter an email address.

　　Then, SAVE AND CONTINUE.
　　

　❷ Scopes
Just SAVE AND CONTINUE.

　➌ Test users
Just SAVE AND CONTINUE.

　➍ Summary
Confirm what you have entered and BACK TO DASHBOARD



⑨ Publish the app.

You may be asked whether to push to production when publishing the app. Confirm
it.

⑩ Go to [Credentials]
　 Click [CREATE CREDENTIALS] > [OAuth client ID]

⑪ Create OAuth client ID.

　❶ Select “Web application” for Application type.



　❷ Name the application.

　➌ Add an Authorized redirect URI*.

　　 *Copy “Redirect URI” which is on Backup Settings of GABQ and paste it.

　

　➍ CREATE.

⑬ Now you have created the project (app) and set OAuth client that is needed for
GABQ.

　 Copy “Client ID” and “Client Secret”.

(2) Return to the GABQ Backup Settings, and enter the "Client ID" and "Client Secret"
for the project (app) created at Google Cloud.

(3) Click "Authenticate".

(4) When "Sign in with Google" appears, choose your account.
　Be sure to choose a Google account that is authorized to view the data to be
downloaded.



It is estimated to take about 5 to 10 minutes to be able to select the download source
after API authentication. (In some cases, it may take longer.)

If you selected the wrong Google account to be linked:

Redo the API Integration before starting the download.
Click “Unlock the button's disabled”; enter the right client ID and the client secret; and

then authenticate again.



5. Selecting Download Source and Starting Backup (Backup
Settings ②)

Check✔️

PHP “max_execution_time” and “memory_limit” are configured to appropriate
values.

● Preparation Guide
https://ga-backup.com/wp-content/uploads/gabq-preparation-guide_EN.pdf

● About “Backup Mode”

Determine the data to be downloaded by selecting in "view" units of Google Universal
Analytics.

⚠️If you selected the wrong Google account to link, please make sure to re-link the account
BEFORE starting the download. (Please refer to the previous section 4 for how to redo
the process.)

⚠️If you don't see the list of "Your Views of Universal Analytics," it's possible that the Google
Cloud application hasn't been configured correctly. Please return to step 4, which is
Google API Integration, and ensure that both libraries, "Google Analytics Reporting API"
and "Google Analytics API", are enabled.

https://ga-backup.com/wp-content/uploads/gabq-preparation-guide_EN.pdf


１）Select the data to backup.
The views for which the Google account linked to the API has access permission will

be listed. (There is no grouping by analytics account or property.)
Select the views you want to back up.
▶ Please also read the "Note" in the red frame below.

２）Click "Start Downloading data from UA" to start backup.*

You don’t have to select all data to back up in a step of “Backup Settings ② Selecting
Data to Backup”. You can select data to download also in the following "Backup Settings
③ Backup Status”.

* Limitations and consumption of view counts in the license.
A License has a limit on the number of views which can be backed up.
The number of views in a license will be consumed at the start of downloading.
It cannot be undone after starting to download data even if you make a mistake in
your view selection.

※NOTE※

When there are many views to choose from,
there will be a scroll bar on the right side of the view list.

After scrolling the scrollbar, there might be a momentary white screen flash.
　Scrolling within the table might take 1-2 seconds for rows to become visible.　　
Even when reaching the bottom of the table, due to scrolling effects, new rows
might appear a few seconds later.
　Please have patience and wait a few seconds to display the rows.



6. Backup Status and Additional Downloads (Backup Settings
③)

"Time Required" and "Estimated End Date" are estimates. It may take longer than the
estimated period due to the influence of server conditions and communication.

Colors of ● symbol next to Domain indicates:
● Green・・・Download Completed
● Yellow・・・Download in progress
● Red ・・・Not downloading

　

★ Additional Backups

(e.g.) If you have a 10-view license and have only backed up 6 views, you can backup 4
more views.

Select the views you want to download from UA, select "Start backup" and click "Apply".
(This will consume the counts of views in your license.)

※NOTE※

When there are many views to choose from,
there will be a scroll bar on the right side of the view list.



After scrolling the scrollbar, there might be a momentary white screen flash.
　Scrolling within the table might take 1-2 seconds for rows to become visible.　　
Even when reaching the bottom of the table, due to scrolling effects, new rows
might appear a few seconds later.
　Please have patience and wait a few seconds to display the rows.

★ Backup with Highest Priority

The views are backed up in order from the top of the list.

(e.g.) To make the sequential (order of) No. 3 to No. 1, check the box, select "Move to
the top," and click "Apply".

7. About “Backup Mode”

If your server has less than 4GB of memory, which is a recommended specification,, GABQ
will automatically operate in a “stable mode” that is optimized to conserve server memory.
This is because on servers with less memory, attempting to retrieve up to 30,000 URLs per
day, as allowed by the Google API specifications, could result in memory errors.

The number of URLs retrieved in relation to PHP's memory_limit value is outlined in Table A
below.

GABQ initiates backups by downloading data from pages with higher traffic. If the number of
URLs retrieved by GABQ, based on PHP's memory_limit value , is lower than the count of
URLs reported in UA's 'All Pages' report, there might be pages with lower traffic that won't be
included in the backup process. As a result, the overall number of backed-up pages could be
reduced.

(Table A)



memory_limit Approximate number of URLs
retrieved per day

256M or more 1000-3000

512M or more 2000-5000

1000M or more 3200-8000

2000M or more 4000-10000

3500M or more 10000-30000

■ This is an estimate when a server is used exclusively for GABQ.
■ The values presented in the table are intended as approximations
and should not be considered as absolute guarantees.

8. Creating and Managing Data Users

You can create exclusive users for particular backed up data.
When you log in to WordPress as a data user, you will see only the data view screens of
GABQ. (You will not see or have access to any other admin menus except GABQ’s data
view screens.)
Only authorized data can be handled in GABQ. (Data users can view summary reports
and download CSV files of data to which permission is given.)

▼ How to Create

１）Creating a data user

(1) Go to “Data Users”.

(2) Click "Add New".

(3) Enter the email address and password, and click "Add New Data User".
Email address and password are required to login WordPress.

The password should be at least 12 characters long.
Simple ones like 123... or aaa... are considered vulnerable to WP and you may be
asked to reset your password when logging in.



２）Granting Access Permissions

Assign which of the backup data each user can access.

(1) Click "Access Permissions" of a user.

(2) Check the data to be granted access to the user.

(3) Click "Save permissions".

■ If You Lost the Password

(It is the same way to change the password of a WP user.)
You can change a user's password from WordPress admin > Users > User List.
A user can also change their password from the "Lost your password?” link on the
WordPress login page. An email to change the password will be sent to the user.

■ To Delete a Data User

You can delete a data user from GABQ > Data Users > "Delete" of the user.



9. Supported Browsers

● Google Chrome



Updates of Analytics Backup by QA 　　　　
GABQ will continue to undergo upgrades in the future.

There are two methods for updating GABQ: "Automatic" and "ZIP."
Primarily, updates will be performed using the "Automatic Update" method.

Method Update Procedure
Update Management Number

Plugin Version Update Number

Automatic
Update Not required (automatic) No changes Will change

ZIP
Update Manual update required Will change

Will change
(There might be
instances where it
reverts to 00)

Update Management Number

There are two types:

● Plugin Version
... Located in WordPress Dashboard > Plugins > Analytics Backup by QA section.

● Update Number
... GABQ's unique management number.
Can be found in Analytics Backup by QA > Help > Debug section under

"update_no".



Update Procedure

■ For automatic updates, there is no need to do anything in particular.

■ In the case of updates through zip distribution, you will receive an email notification about
the version update.
Please update GABQ in the following way:

▼How to update with a zip
1) Download the latest version zip file from the download page of GABQ site.

2) Go to WordPress admin > Plugins > Add New > Upload Plugin.
Upload the new version zip file.

3) Select "Replace current version with uploaded one" to update.

If you need to do any special operations or settings, we will inform you by email or on the
download page. Please update and configure according to the instructions provided.

WP version 5.9 or higher is required.
　If your WP version is older than WP5.9, some problems may occur, such as the inability
to update by zip upload and double installation of GABQ.
　If you find that GABQ has been installed twice, please delete GABQ by FTP or other
appropriate means. (Be sure to do this by someone familiar with the operation.) Please
note that uninstalling one of them from the WP admin screen will result in the deletion of
ALL the data that has been backed up until then.

* Using FTP to update GABQ is NOT recommended, especially if you are not very familiar
with it.


